Log availability and search performance temporarily degraded

Incident Report for Mezmo Status Page

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 22:29 UTC

Investigating

The cause is known and is being actively mitigated.
Posted Apr 14, 2025 - 20:12 UTC