Issues accessing logs in boards and screens

Incident Report for Mezmo Status Page

Resolved

This incident has been resolved. All services are fully operational.
Posted Apr 11, 2025 - 21:03 UTC

Investigating

We are currently investigating this issue.
Posted Apr 11, 2025 - 19:17 UTC
This incident affected: Log Analysis (Web App).